Hi,

I tried to compile the 2.2.10 version on my newly installed Mandriva 2006.0 (it compiled perfectly on Mandriva 2005), but I now get the following error while compiling the image map plugin. Any one has a clue ?



gcc -g -O2 -Wall -o .libs/imagemap imap_about.o imap_browse.o imap_cern_lex.o imap_cern_parse.o imap_circle.o imap_cmd_clear.o imap_cmd_copy.o imap_cmd_copy_object.o imap_cmd_create.o imap_cmd_cut.o imap_cmd_cut_object.o imap_cmd_delete.o imap_cmd_delete_point.o imap_cmd_edit_object.o imap_cmd_gimp_guides.o imap_cmd_guides.o imap_cmd_insert_point.o imap_cmd_move.o imap_cmd_move_down.o imap_cmd_move_sash.o imap_cmd_move_selected.o imap_cmd_move_to_front.o imap_cmd_move_up.o imap_cmd_object_down.o imap_cmd_object_move.o imap_cmd_object_up.o imap_cmd_paste.o imap_cmd_select.o imap_cmd_select_all.o imap_cmd_select_next.o imap_cmd_select_prev.o imap_cmd_select_region.o imap_cmd_send_to_back.o imap_cmd_unselect.o imap_cmd_unselect_all.o imap_command.o imap_csim_lex.o imap_csim_parse.o imap_default_dialog.o imap_edit_area_info.o imap_file.o imap_grid.o imap_main.o imap_menu.o imap_menu_funcs.o imap_misc.o imap_mru.o imap_ncsa_lex.o imap_ncsa_parse.o imap_object.o imap_object_popup.o imap_polygon.o imap_popup.o imap_preferences.o imap_preview.o imap_rectangle.o imap_selection.o imap_settings.o imap_source.o imap_stock.o imap_statusbar.o imap_string.o imap_table.o imap_taglist.o imap_toolbar.o imap_tools.o ../../libgimp/.libs/libgimpui-2.0.so ../../libgimpwidgets/.libs/libgimpwidgets-2.0.so ../../libgimp/.libs/libgimp-2.0.so ../../libgimpcolor/.libs/libgimpcolor-2.0.so ../../libgimpbase/.libs/libgimpbase-2.0.so -L/usr/X11R6/lib /usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libatk-1.0.so /usr/lib/libgdk_pixbuf-2.0.so /usr/lib/libpangocairo-1.0.so /usr/lib/libpango-1.0.so /usr/lib/libcairo.so /usr/lib/libgobject-2.0.so /usr/lib/libgmodule-2.0.so -ldl /usr/lib/libglib-2.0.so /usr/lib/libfreetype.so /usr/lib/libfontconfig.so -lXrender -lX11 -lXext -lpng12 -lz -lm
imap_csim_parse.o: In function `csim_error':
/home/olive/src/gimp-2.2.10/plug-ins/imagemap/imap_csim.y:315: undefined reference to `csim_in' /home/olive/src/gimp-2.2.10/plug-ins/imagemap/imap_csim.y:315: undefined reference to `csim_restart'
imap_csim_parse.o: In function `csim_parse':
/home/olive/src/gimp-2.2.10/plug-ins/imagemap/y.tab.c:1116: undefined reference to `csim_lex'
imap_csim_parse.o: In function `load_csim':
/home/olive/src/gimp-2.2.10/plug-ins/imagemap/imap_csim.y:323: undefined reference to `csim_in' /home/olive/src/gimp-2.2.10/plug-ins/imagemap/imap_csim.y:327: undefined reference to `csim_in'
collect2: ld returned 1 exit status
make[4]: *** [imagemap] Erreur 1
make[4]: Leaving directory `/home/olive/src/gimp-2.2.10/plug-ins/imagemap'
make[3]: *** [all-recursive] Erreur 1
make[3]: Leaving directory `/home/olive/src/gimp-2.2.10/plug-ins/imagemap'
make[2]: *** [all-recursive] Erreur 1
make[2]: Leaving directory `/home/olive/src/gimp-2.2.10/plug-ins'
make[1]: *** [all-recursive] Erreur 1
make[1]: Leaving directory `/home/olive/src/gimp-2.2.10'
make: *** [all] Erreur 2


I tried disabling python, but it still fails. I configure without print support. The only library configure complains of is the aa one, but it only prints a warning, not an error. And I do not need ascii art support anyway.

Thanks for the tips,

Best regards,

Olivier.

PS: for the list of versions of the various libraries in Mandriva 2006:
http://wwwnew.mandriva.com/en/individuals/products/2006discoverylx/packages32

_______________________________________________
Gimp-user mailing list
Gimp-user@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user

Reply via email to