On Fri, Feb 10, 2006 at 11:43:55PM -0500, Scott wrote:
> > On Fri, Feb 10, 2006 at 02:27:42PM -0500, Scott wrote:
> >>
> >> gimp-composite-sse.c: In function
> >> 'gimp_composite_scale_rgba8_rgba8_rgba8_sse':
> >> gimp-composite-sse.c:786: error: PIC register '%ebx' clobbered in 'asm'
> >> make[3]: *** [libcompositesse_a-gimp-composite-sse.o] Error 1
> >> make[2]: *** [all-recursive] Error 1
> >> make[1]: *** [all-recursive] Error 1
> >> make: *** [all] Error 2
> >>
> >> -----------------------------------------------------
> >>
> >> I then can seem to run a make install, but there is no gimp executable.
> >> Only gimp-remote seems to get installed. Can someone perhaps lead me in
> >> the right direction with this?
> >>
> > recently there was the same problem with mmx.  if you run ./configure
> > --help it will tell you how to build without this sse stuff.  these are
> > some "optimizations" that were included by some guy from Sun and seem to
> > be unmaintained lately.
> 
> I ran it with --disable-mmx, now ld does not support the -rpath switch on
> OS X. And there does not seem to be an option to disable it in the
> configure, at least that I found .
> 
i took a few seconds and ran ./autogen.sh --help and i found an option
to --enable-sse            enable SSE support (default=auto)

this is what the error message complained about.  the error message did
not complain about mmx although, i think that disabling it should not
have messed up -rpath.  

i am sorry if using mmx as a suggestion to look for sse configuration
options was confusing.

carol

_______________________________________________
Gimp-user mailing list
Gimp-user@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user

Reply via email to