On Monday 17 April 2006 21:14, Geoffrey wrote:
> David Lee wrote:
> > On Mon, 17 Apr 2006 08:37:17 -0400 Jim Philips
> >
> > <[EMAIL PROTECTED]> wrote:
> >> I have some 3x5 templates in .png format that I downloaded. I want
> >> to print them out in landscape format, because if I print them as
> >> portrait my printer bracket won't come in tight enough to hold the
> >> card in place. So, I open the .png in Gimp and flip it 90 degrees
> >> and save it. I then try to print it from Gimp, with 3x5 specified
> >> as the paper size. What gets printed is a long string of raw
> >> Postscript and nothing else. I have to kill the print job. I'm
> >> using Gimp 2.2.10 with CUPS 1.1.23 on a Slackware box. Any clues as
> >> to what is wrong? Am I using a crappy print driver? The printer is
> >> an Epson C-62 inkjet. It prints without problems otherwise, even
> >> some 3x5 cards in landscape. But those are from a Web page where
> >> formatting is enforced by CSS.
> >
> > I believe you will need to pick "setup printer" from the print dialog
> > and pick the type of printer you are using.  This is what did the
> > trick for me.
> One thing I recall about the GIMP is that it wants a non compressed ppd
> file.  What I've had to do is go to the directory where they exist and
> unpack the file there.  Make sure you retain the gunzipped version
> though because other applications look for it.  For example, for my
> Minolta laser I have the following ppd files:
> /usr/share/cups/model/Minolta-magicolor_2300_DL.ppd
> /usr/share/cups/model/Minolta-magicolor_2300_DL.ppd.gz
> You set this in the setup printer dialog of GIMP David has mentioned.

OK. I went through the printer setup. Now I don't get the Postscript garbage 
when I print. What I do get is my printer attempting to print in portrait 
format even though the file is saved in landscape format. So, the next time I 
tried I went to the Image Output tab of the print dialog and changed it to 
landscape format. And voila! The garbage Postscript output returned. I don't 
have the ppd file, since I'm using Gimp-Print and it doesn't seem to need 
that. I found at least one indication in somebody else's post that this is a 
CUPS issue. Anyway, I'm still feeling thwarted.
Gimp-user mailing list

Reply via email to