I'm operating under openSuse 10.2 on an x86_64 system and recently downloaded 
and installed a precompiled gimp-unstable 2.3.13.  When I ran the program I 
found that I couldn't open or save any images without it crashing.  So I 
removed it, restarted a 2.2 version, and found a different problem - I could 
only open specific types of files.

I tried running both Gimp versions in verbose mode.  Always I was confronted 
with the '[E]xit, [H]alt, show [S]tack trace or [P]roceed:', with no obvious 
information before hand as to what was going on.  Frustrated, I uninstalled 
all things Gimp, downloaded the source for 2.3.13, built and installed it.

The build and install succeeded without incident.  I can go into the Gimp and 
do whatever I please, with any of the tools just like before.  But if I try 
and load or save a file, the Gimp dies the same ugly death as before, without 
indicating what the problem is.  What follows is what I'm hoping is enough of 
the stack trace to give someone a clue as to what might be happening:

#0  0x00002af7c958cc5f in waitpid () from /lib64/libpthread.so.0
#1  0x00002af7cb37afb8 in g_on_error_stack_trace ()
#2  0x00002af7cb37b527 in g_on_error_query ()
#3  0x0000000000429d04 in gimp_eek (reason=0x66e3e5 "fatal error",
#4  0x0000000000429e7d in gimp_fatal_error (fmt=<value optimized out>)
#5  0x0000000000429919 in gimp_sigfatal_handler (sig_num=<value optimized 
#6  <signal handler called>
#7  0x00002af7cb67b064 in strcmp () from /lib64/libc.so.6
#8  0x000000000058f998 in gimp_recent_list_add_uri (uri=<value optimized out>,
#9  0x000000000058daf1 in file_save (image=0x1870050, context=0xb8e150,
#10 0x000000000044ff48 in file_save_dialog_response (save_dialog=0x1f628d0,

It looks like the fatal error happens right after the strcmp().  Could there 
be an issue with locale???

Let me know and best regards as always,



Attachment: pgpXi7PrNL02n.pgp
Description: PGP signature

Gimp-user mailing list

Reply via email to