Hi,

On Thu, 2007-01-18 at 11:50 -0500, Bogolisk wrote:

> Is it because I dont have gdk-pixbuf installed? I thought gdk-pixbuf
> is for gtk1.2 only and not needed for gtk2.

It is part of gtk2, so you most probably have it installed.

> make[3]: Entering directory `/home/linhd/build2/gimp-2.3.13/libgimpwidgets'
> if /bin/bash ../libtool --tag=CC --mode=compile i486-linux-gnu-gcc 
> -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include/gtk-2.0 
> -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo 
> -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  
>  -I/usr/include -DG_LOG_DOMAIN=\"LibGimpWidgets\" -pthread 
> -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   
> -DGIMP_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED 
> -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED 
> -DGTK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE 
> -DGTK_MULTIHEAD_SAFE  -Wall -g -O2 -Wdeclaration-after-statement 
> -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -MT 
> gimpstock.lo -MD -MP -MF ".deps/gimpstock.Tpo" -c -o gimpstock.lo 
> gimpstock.c; \
>         then mv -f ".deps/gimpstock.Tpo" ".deps/gimpstock.Plo"; else rm -f 
> ".deps/gimpstock.Tpo"; exit 1; fi
>  i486-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include/gtk-2.0 
> -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo 
> -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include 
> -I/usr/include -DG_LOG_DOMAIN=\"LibGimpWidgets\" -pthread 
> -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DGIMP_DISABLE_DEPRECATED 
> -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED 
> -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED 
> -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -Wall -g -O2 
> -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations 
> -Winit-self -Wpointer-arith -MT gimpstock.lo -MD -MP -MF .deps/gimpstock.Tpo 
> -c gimpstock.c  -fPIC -DPIC -o .libs/gimpstock.o
> gimpstock.c:334: error: 'stock_anchor_16' undeclared here (not in a function)
> gimpstock.c:335: error: 'stock_center_24' undeclared here (not in a function)
> gimpstock.c:336: error: 'stock_duplicate_16' undeclared here (not in a 
> function)
> gimpstock.c:337: error: 'stock_edit_16' undeclared here (not in a function)
> gimpstock.c:338: error: 'stock_paste_as_new_16' undeclared here (not in a 
> function)
> gimpstock.c:339: error: 'stock_paste_into_16' undeclared here (not in a 
> function)

Probably a hickup with make dependencies. Try 'make -C themes clean' and
attempt a rebuild.


Sven


_______________________________________________
Gimp-user mailing list
Gimp-user@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user

Reply via email to