I'm using a Debian Sid distribution, regularly updated. I have the
gimp-2.2 Debian package, last modification on 2007-07-13:

% ls -l =gimp-2.2
-rwxr-xr-x 1 root root 3,0M 2007-07-13 19:26 /usr/bin/gimp-2.2*

I have also gimp-2.3.19, installed in /usr/local and correctly working,
but with an interface to gutenprint I cannot manage properly (I would
like to enlarge a picture automatically to paper size, and it does not
seem to work).

When I call gimp-2.2, I get the flash picture of version 2.3, then the
following messages:

% gimp-2.2

(gimp-2.2:15902): GLib-GObject-WARNING **: cannot register existing type 
`GimpConfigInterface'

(gimp-2.2:15902): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: 
assertion `G_TYPE_IS_INTERFACE (interface_type)' failed

(gimp-2.2:15902): GLib-GObject-CRITICAL **: g_type_add_interface_static: 
assertion `g_type_parent (interface_type) == G_TYPE_INTERFACE' failed

(gimp-2.2:15902): GLib-GObject-WARNING **: cannot register existing type 
`GimpConfigInterface'

(gimp-2.2:15902): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: 
assertion `G_TYPE_IS_INTERFACE (interface_type)' failed

(gimp-2.2:15902): GLib-GObject-CRITICAL **: g_type_add_interface_static: 
assertion `g_type_parent (interface_type) == G_TYPE_INTERFACE' failed

(gimp-2.2:15902): GLib-GObject-WARNING **: cannot register existing type 
`GimpParamRGB'

(gimp-2.2:15902): GLib-GObject-CRITICAL **: g_param_spec_internal: assertion 
`G_TYPE_IS_PARAM (param_type) && param_type != G_TYPE_PARAM' failed
zsh: segmentation fault  gimp-2.2

I removed and purged the Debian package, then re-installed it, without
no success. Where is my mistake? What should I try?

Thanks in advance for any help and suggestion.

-- 


                        Olivier Lecarme
_______________________________________________
Gimp-user mailing list
Gimp-user@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user

Reply via email to