You must supply the appropriate drawable ID to the plug-in. Per your example:

(plug-in-autocrop 1 4 (car (gimp-image-get-active-layer 4)))

Quoting Sam Kuper <[EMAIL PROTECTED]>:

> I want to apply a filter plug-in via the script-fu console, but this doesn't
> seem to work. I have tried with several plug-ins, with no success. I have
> tried this on GIMP 2.0.5 on RedHat Enterprise Linux and GIMP 2.4.1 on
> Windows XP SP2.
> Let's take a simple example. Suppose I have a .png image open in GIMP, and
> it is image 4. It has only one layer. It has an excessive white border, so I
> want to autocrop it.
> If I go to the script-fu console and enter:
> (plug-in-autocrop 1 4 0)
> In 2.4.1 on WinXP I get a message "Error: Procedure execution of
> plug-in-autocrop failed" and the error console displays a series of errors:
> ...
> If I use a number other than 0 for the drawable, however (I've tried every
> integer from -2 to 2) then I still get an error. (NB. on Linux the situation
> is no better, but the error messages are different.)

Gimp-user mailing list

Reply via email to