David Gowers wrote:
> On Tue, Dec 16, 2008 at 10:08 PM, peter kostov <g...@light-bg.com> wrote:
>> Doug wrote:
>>> peter kostov wrote:
>>>> Hi,
>>>>
>>>> does anybody know if the normalmap and the resynthesizer plug-ins do
>>>> work with GIMP 2.6?
>>>>
>>>> I am on Gentoo and currently have two different versions of GIMP - 2.4
>>>> installed system wide and 2.6 installed only for me. I use 2.4 when I
>>>> need these plug-ins and 2.6 for everything else.
>>>> Currently if I try to use these and other plug-ins (I am not speaking
>>>> of these that came with the GIMP itself) with GIMP 2.6 I am getting an
>>>> error message like this:
>>>>
>>>> gimp_plug_in_handle_proc_run: ERROR
>>>>
>>>> Could not execute plug-in "normalmap"
>>>> (/home/peter/.gimp-2.6/plug-ins/normalmap)
>>>> because it uses an obsolete version of the plug-in protocol.
>>>>
>>>> Greetings,
>>>> Peter Kostov
>>>>
>>>> _
>>> Hi,
>>> I have resynthesizer working on 2.6.3.
>>>
>>> Doug
>>>
>> That's good!
>>
>> I know I have to recompile them, but I don't know how to recompile them
>> against a specific version of GIMP, not the system wide installed. And
>> that is why I decided to ask you, before I upgrade my GIMP system wide.
> Well, if you use the gimptool belonging to your 2.6 GIMP to compile
> the plugin, rather than the systemwide gimptool, that should be
> effective.
> 
> David
> 

Hm, thanks David, but it isn't so easy, because the package uses 
pkg-config too. So I tried to alter the Makefile by defining the path to 
the new gimptool and adding 
--define-variable=prefix=/home/peter/install/gimp to the pkg-config 
command to tell it where to search for libraries, but then the make 
failed with LOTS of errors like this:
/home/peter/install/gimp/include/gimp-2.0/libgimpcolor/gimpcolorspace.h:76: 
error: expected ')' before '*' token


Greetings,
Peter
_______________________________________________
Gimp-user mailing list
Gimp-user@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user

Reply via email to