Quoting Nicholas I <nicholas.domni...@gmail.com>:

>  i am using ubuntu 8.3, i did a sudo apt-get install gimp, it did not
> upgraded to the newest version, ...

Your repositories probably do not have the newest version available.

> ... i tried installing from source but i had lot
> of problem in installing it. i just left it.

If you reached the point of performing 'sudo make install' then you  
have installed the new version of GIMP. If you used the default PREFIX  
then it was installed to /usr/local/ .

You should not have "just left it". You should remove it. You can  
remove it using 'sudo make uninstall' from the source build directory  
(the same directory in which you ran 'sudo make install'). You could  
also do something such as the following (but it is a little bit risky,  
depending on what you have in /usr/local):

find /usr/local -name gimp\* -exec sudo rm -vr {} \;

> now when i run gimp from command propmt
> i get the following error.
> *Libgimp version mismatch!
> The GIMP binary cannot run with a libgimp version
> other than its own. This is GIMP 2.4.5, but the
> libgimp version is 2.6.0.
> Maybe you have GIMP versions in both /usr and /usr/local ?*
> i tried renaming the folders but still the problem is not solved.

I do not know what this means.

> any help? please

If you want to compile GIMP from source but retain a packaged version,  
I would recommend using a PREFIX of '/opt/gimp' or somesuch.

     ./configure --prefix=/opt/gimp && make && sudo make install

Do not install to '/usr/local' because '/usr/local/lib' is typically  
included in the library search path (by virtue of it being listed in  
'/etc/ld.so.conf') and your packaged version of GIMP will try to link  
to the GIMP libraries in '/usr/local/lib'. (This is likely the problem  
you encountered.)

When you install GIMP to '/opt/gimp', the GIMP libraries will be  
created in '/opt/gimp/lib' which is not part of the default library  
search and so they will not interfere with the packaged version.

In order to run your new version, you will have to specify where its  
libraries are to be found (since '/opt/gimp/lib' is not in the library  
search path). This is typically done by setting the LD_LIBRARY_PATH  
environment variable and then invoking your new GIMP:

    LD_LIBRARY_PATH=/opt/gimp/lib /opt/gimp/bin/gimp

Do not set LD_LIBRARY_PATH globally (e.g., in your .bashrc) as this  
will interfere with your packaged GIMP. It would probably be best to  
create a shell script which executes the above command; that way  
LD_LIBRARY_PATH will only be redefined within the script and not  
interfere with other programs.

Gimp-user mailing list

Reply via email to