Ok, I have made progress.  It appears that Gimp 2.6 does not like "aset!", so I 
had to change it to "vector-set!" to make gimp take it.
Note this page stating that "aset" was deprecated back in gimp 2.4: 

Script-fu gives me much better error messages.  With my current script, I get 
this response, which I think means null:

The image does not appear to have been modified at all, so there is still 
something wrong.

Currently, I am using this line, via script-fu, to run my script:

(color-curve "C:\\gimpbatchtest\\*.tiff")

And the script itself:

(define (color-curve pattern)
(let* ((filelist (cadr (file-glob pattern 1))))
    (while (not (null? filelist))
        (let* ((filename (car filelist))
            (image (car (gimp-file-load RUN-NONINTERACTIVE filename filename)))
                (drawable (car (gimp-image-get-active-layer image))))
                    (let* (
                    (my-curve (make-vector 6 'byte))
                    (vector-set! my-curve 0 0)
                    (vector-set! my-curve 1 0)
                    (vector-set! my-curve 2 208)
                    (vector-set! my-curve 3 17)
                    (vector-set! my-curve 4 255)
                    (vector-set! my-curve 5 255)
                    (gimp-curves-spline image
                        HISTOGRAM-VALUE 6 my-curve)
                (gimp-file-save RUN-NONINTERACTIVE image drawable filename 
                (gimp-image-delete image))
            (set! filelist (cdr filelist)))))

Thanks in advance.


Gimp-user mailing list

Reply via email to