Hi,

I run this command from the (linux) commandline:

gimp -i -b '(batch-unsharp-mask "*.jpg" 5.0 0.5 0)' -b '(gimp-quit 0)'

The response to this command is:

batch command experienced an execution error

If I comment out the line with 'gimp-image-scale', the batch processing
works but off course without scaling.

Since the 'let' statement creates local variables I also tried to put
the 'gimp-image-scale' line within the braces, but this also results in
the same error message. I tried to debug the script using the Scheme
command display, but this was also unsuccesfull.
The calculation of the scale variable works in Scheme using Guile, so
that part of the script should be OK. But now I am stuck.

Regards,

Eric



Sven Neumann wrote:
> Hi,
> 
> On Mon, 2009-08-17 at 20:27 +0200, Eric van Oorschot wrote:
> 
>> How do I batch process files in gimp and resize the images while keeping
>> the aspect ratio of the original file. I modified the batch processing
>> example on the Gimp web pages, but it just doesn't work.
> 
> It would help a lot if you told us what exactly does not work.
> 
> 
> Sven
> 
> 
> 


-- 


Kind regards / Vriendelijke groeten,


Eric van Oorschot
Prinsenbeek
_______________________________________________
Gimp-user mailing list
Gimp-user@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user

Reply via email to