is the bug I posted at my
distro's tracker, but its not looking like a packaging error so I
thought I'd ask here instead.

Basically, when I run gimp, I get this error after startup:-

(gimp:15432): Gimp-Widgets-CRITICAL **: gimp_device_info_set_device:
assertion `(info->device == NULL && GDK_IS_DEVICE (device)) ||
(GDK_IS_DEVICE (info->device) && device == NULL)' failed

Then, if I open a new image (or existing image) and click on some tool
(for example the text tool), once I try to click on the canvas using
that tool I get the following error in the terminal:-

gimp_display_shell_pointer_grab: gdk_pointer_grab failed with status 1

>From that point on, I can't select any other tools (or even the menu
items). My WM shortcut keys still work so I can quit gimp fine.

The odd thing is that on an almost identical system (both 64-bit
Archlinux installs running awesomewm with almost identical packages
installed) this works. I've tried the following:-
1. Switching WM to Gnome3. This works, I don't get the same error in
Gnome3 with gnome-shell.
2. Changing gtk2 and gtk3 themes. Does not work.
3. Switching to a single monitor (I use dual-monitors on the affected
system but not on the other). Does not work.
4. Deleting ~/.gimp-2.7. Does not work.

I have not tried switching video driver to nouveau (the other
difference between the systems is that the affected system is using
nvidia, the other intel-based graphics).

Anyone have any idea what I could try to do?
Gimp-user mailing list

Reply via email to