I have a problem compiling and installing the 1.1.11 version of the GIMP on
my Linux box, and would greatly appreciate any help on this subject.
After unpacking the source tarball, I started ./configure, which - as far
as I can tell - did not complain about anything missing or outdated.
Subsequently I ran make, and was perplexed to notice that the compilation process
failed with messages like " ... file "X11/Xlib.h" included from foo.c: File
does not exist" (I don't remember the exact wording).
So I installed the XFree 3.3.4 sources, and looked for the required files
there, with success. My question is: how do I make "make" clear where to
look for them?

Things I tried and wich didn't work:
- copying all the required files to /lib/X11 (since in the source they are
all referred to as "X11/foo.h")
- adding the path to the X sources to ld.so.conf
- starting ./configure with the --x-libraries=[PATH] switch
- desperatedly, hard-coding the correct path into the source files (which
does work, but there are too many of them and it is catastrophically

I would be very grateful for any advice from people who know more about
compilation arcana than I do.

Thomas Fischer (tfischer_at_gmx.ch)

Sent through Global Message Exchange - http://www.gmx.net

Reply via email to