I am trying to compile gimp-1.1.19.

Perl version is 5.6.0. The only change I made during the setup script was
to enable threads.

When I compile gimp I get errors like this:

Lib.xs:2186: too few arguments to function `Perl_croak'
Lib.xs: In function `XS_Gimp__Lib_gimp_tile_set_data':
Lib.xs:2197: warning: passing arg 1 of `Perl_croak' from incompatible
pointer type
Lib.xs:2197: too few arguments to function `Perl_croak'
make[4]: *** [Lib.o] Error 1

I also get similar errors when compiling PDL.

Before I enable threads in perl all of this compiled ok.

I realize this is a perl problem, however, since perl is integral to gimp
maybe some gimp users have run across this problem.

I appreciate any help.

Thanks,

::::: Gene Imes                      http://www.ozob.net :::::

Reply via email to