In short form:

./configure --host=linux

In fuller form:
The instructions I referred to are now at
They weren't meant to solve your perl problems though as they are intended as a
quick and simple way of installing the gimp for new users, ie: perl is

On Sun, 06 Aug 2000, you wrote:

> So, I have located an RPM which contains the perl plug-ins (I downloaded
> about three different GIMP v1.1.24 RPM packages, 
The problem here would seem to be the mandrake rpm files (I'm assuming you are
using mandrake) and it looks as if the people who packed the rpm's were/are
using a slightly different version of perl to the one you have. This is likely
to be outdated by now and (I'm guessing you picked them up at the developer
site) no longer available for download. This is a serious shortfall on use of
rpm's for the end product package (ie the gimp) as compared to use of rpm's for
updating base product packages (ie libs) where they tend to be less dependent
on very minor revisions.. 

> and I noted with interest
> that they don't all have the same files - some are missing the perl
> components).
again probably due to different rpm packers using a different setup on their
individual machines. (check the name of the packer if you use krpm manager)

> However, I am still having problems (mainly it seems I am unable to upgrade
> gtk and perl due to dependencies) and was wondering if I could get some help
> to resolve this.
> (1) When I attempted to install from this RPM (rpm -ivh
> gimp-1.1.24-2.i686.rpm), I got the following errors :
> "error: failed dependencies:
>  perl = 5.005_03 is needed by gimp-1.1.24-2
>  /usr/lib/perl5/site_perl/5.005/i686-pld-linux-thread is needed by
> gimp-1.1.24-2
So either --disable-perl or if you really want the perl enabled, get the
version of perl. If I remember correctly mandrake 7.0 comes with
site_perl-5.004 but if you fetch mandrake rpm updates they will install
ALONGSIDE your old site_perl not replacing it, at least, when I fetched 5.6 they
did. hence my question on the list about where the references are in the config

>  gtk+ >= 1.2.8 is needed by gimp-1.1.24-2
>  perl(Carp) is needed by gimp-1.1.24-2
>  perl(DynaLoader) is needed by gimp-1.1.24-2
>  perl(Exporter) is needed by gimp-1.1.24-2"
>  (etc.).....
> (2) So, then I downloaded an RPM for gtk-1.2.8  and attempted to upgrade as
> follows (rpm -Uvh gtk-1.2.8-24.i386.rpm), but got a long string of errors
> similar to the following :
You got to force replce files here as mandrake install gives you the gtk1.2.6
developer files as well (dependency) don't worry about anything else yet
> "file /usr/share/locale/ca/LC_MESSAGES/ from install of gtk-1.2.8-24
> conflicts with file from package gtk+-1.2.6-6mdk"
> Note that I was unable to simply uninstall gtk-1.2.6 - when I did this it
> gave me a long list of programs (dependencies) which required GTK.
see above

> (3) Finally, I downloaded a perl RPM package, and tried to updgrade it
> (rpm -Uvh perl-5.005_03-172.i386.rpm), and got errors like the following :
> "package perl-5.00503-10mdk (which is newer then perl-5.005_03-172) is
> already installed
> file /usr/bin/perl from install of perl-5.005_03-172 conflicts with file
> from package perl-base-5.00503-10mdk..."
> If this is already installed why was I getting all of those perl-related
> dependency errors when installing GIMP ?
gimp cant find your version of perl, mandrake (as with everything) hides it away
seperate to other installations
> Thanks in advance,
> Andrew

marc lehmann wrote
>On Mon, Aug 07, 2000 at 04:06:08PM +0100, DM Knight
>>I don't think gimp will configure with perl
>>5.6 as the config files point

>The gimp (source) will configure with perl 5.6 for sure, but if and only if
>perl5.6 is installed correctly. (It's not more difficult to install 5.6
t>han 5.005).

>> be very wrong on this point though. Any one know for sure? Anyone know which
>> config files other than in the perl subdirectory need to be hand edited (I

>No config files need to be hand-edited. Just make sure that the perl in
>your paht is the one you want tp use (or set the PERL env. variable).


>andrew fortune wrote
>I couldn't find your instructions. In any event, I re-tried compiling from a
>sub-directory under my root directory, and got the following error during
>./configure :

>loading cache ./config.cache
>checking for a BSD compatible install... /usr/bin/install -c
>checking whether build environment is sane... yes
>checking whether make sets ${MAKE}... yes
>checking for working aclocal... found
>checking for working autoconf... found
>checking for working automake... found
>checking for working autoheader... found
>checking for working makeinfo... found
>checking host system type... configure: error: can not guess host type; you
>must specify one

OK you have most of perl installed and are no longer using your gcc compiler. 

./configure --host=linux
and watch the missing locale statements fly by!
when it reaches checking for perl it may still say perl is missing see above
about mandrake and pointing to perl 5.6, thats as far as I got, hopefully you
will have better luck than me though.

>I scoured the newsgroups for a solution to this error. The general consensus
>was that you need to have automake, autoconf and make installed. The problem
>in my case is that I already have these packages installed, but this message 
>still comes up.
Like above, I think you are now coming up with perl rather than gcc as your
catch 22... 

Sorry I've not really been much help,
My opinions are my own except where plagiuarised

Reply via email to