Thanks, James -- and Alan  -- for your persistent help with this problem.
James - in answer to your question (do you never compile things ?), I am a
very inexperienced compiler - at least in the Linux world.

Believe it or not, I have made some progress - although it is still falling
over during the ./configure stage.

I have done the following :

- Re-installed Mandrake Linux from scratch, and chose the 'Developer' option
(I thought that I had done this before, but obviously it didn't recognize my
- Executed "rpm -Uvh --force --nodeps gtk+-1.2.8-1.i386.rpm" to upgrade GTK+
from the 1.2.6 version that was installed.
- Did likewise for glib.
- Executed "rpm -q" for both of these packages to ensure that the latest
version (i.e. 1.2.8) was indeed installed. It was.
- Ensured the version of Perl was up-to-date (v5.00503 I think).
- Copied gimp-1.1.24.tar.gz across to a sub-directory of /root.
- Successfully untarred, i.e. "tar zxvf gimp-1.1.24.tar.gz".
- Ran "./configure --host=i586-pc-linux-gnu".

It successfully got past my previous error. It went much further thru' the
configure, but fell over, as follows :

checking for gtk-config... /usr/bin/gtk-config
checking for GTK - version >= 1.2.8...
*** An old version of GTK+ (1.2.6) was found.
*** You need a version of GTK+ newer than 1.2.8. The latest version of
*** GTK+ is always available from
*** If you have already installed a sufficiently new version, this error
*** probably means that the wrong copy of the gtk-config shell script is
*** being found. The easiest way to fix this is to remove the old version
*** of GTK+, but you can also set the GTK_CONFIG environment to point to the
*** correct copy of gtk-config. (In this case, you will have to
*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/
*** so that the correct libraries are found at run-time))
configure: error: Test for GTK failed. See the file 'INSTALL' for help.
[root@localhost gimp-1.1.24]#

Seeing as I had installed GTK+-1.2.8 and glib 1.2.8, apparently successfully
(see above) - I don't understand why it still says that 1.2.6 is still
installed ?? It must be that some artifacts have been left behind in one of
the config files ?

I looked at the gtk-config file, but was confronted with a very daunting
script. I also enquired on the LD_LIBRARY_PATH environment variable, by
keying in $LD_LIBRARY_PATH at the prompt. It returned nothing. Finally, I
had a look at /etc/, and the contents are as follows, but seem
irrelevant to this problem :


Thanks in advance....


----- Original Message -----
From: James Smaby <[EMAIL PROTECTED]>
Sent: Saturday, August 12, 2000 12:52 AM
Subject: Re: The GIMP v1.1.24 Installation Saga Continues.....

> Boy, you're sure having a tough time.  It seems your compiler
> is configured wrong (do you never compile things?).  I've had
> similar problems on my SGI (I've actually given up on it).  I
> suggest reinstalling the compiler if it doesn't work for other
> source as well (if it normall works, I don't know).  Make sure
> that the compiler is for your architecture; i686 will not work
> on a normal pentium or K6II.  Given that uname gives out i586,
> this could be your problem.  Perhaps somebody else will have a
> better idea.

Reply via email to