Following up on a previous posting, I am still trying to install GIMP
v1.1.24 with the perl plug-ins. As previously mentioned, I tried to compile
the source without any measure of success whatsoever - so I am trying the
approach of installing an RPM.

So, I have located an RPM which contains the perl plug-ins (I downloaded
about three different GIMP v1.1.24 RPM packages, and I noted with interest
that they don't all have the same files - some are missing the perl

However, I am still having problems (mainly it seems I am unable to upgrade
gtk and perl due to dependencies) and was wondering if I could get some help
to resolve this.

(1) When I attempted to install from this RPM (rpm -ivh
gimp-1.1.24-2.i686.rpm), I got the following errors :

"error: failed dependencies:
 perl = 5.005_03 is needed by gimp-1.1.24-2
 /usr/lib/perl5/site_perl/5.005/i686-pld-linux-thread is needed by
 gtk+ >= 1.2.8 is needed by gimp-1.1.24-2
 perl(Carp) is needed by gimp-1.1.24-2
 perl(DynaLoader) is needed by gimp-1.1.24-2
 perl(Exporter) is needed by gimp-1.1.24-2"

(2) So, then I downloaded an RPM for gtk-1.2.8  and attempted to upgrade as
follows (rpm -Uvh gtk-1.2.8-24.i386.rpm), but got a long string of errors
similar to the following :

"file /usr/share/locale/ca/LC_MESSAGES/ from install of gtk-1.2.8-24
conflicts with file from package gtk+-1.2.6-6mdk"

Note that I was unable to simply uninstall gtk-1.2.6 - when I did this it
gave me a long list of programs (dependencies) which required GTK.

(3) Finally, I downloaded a perl RPM package, and tried to updgrade it
(rpm -Uvh perl-5.005_03-172.i386.rpm), and got errors like the following :

"package perl-5.00503-10mdk (which is newer then perl-5.005_03-172) is
already installed
file /usr/bin/perl from install of perl-5.005_03-172 conflicts with file
from package perl-base-5.00503-10mdk..."

If this is already installed why was I getting all of those perl-related
dependency errors when installing GIMP ?

Thanks in advance,

Reply via email to