First, let me congratulate the GIMP developers on a marvelous product. 
In a word WOW!

I will "--disable-perl" since it failed to build on Solaris 8. I observed
that the build command configured resulted in:

Making all in perl
cc -c -I/web/tools/gimp-1.2.0/plug-ins/perl -I../../.. 
-I/web/tools/gimp-1.2.0/plug-ins/perl/../.. -I/opt/gnome/lib/glib/include 
-I/opt/gnome/include -I/opt/gnome/lib/glib/include -I/opt/gnome/include 
-I/usr/openwin/include -I/ot/gnome/include -I/ot/gimp/include 
-I/ot/gnome/lib/glib/include -DGTK_DISABLE_COMPAT_H  -g -O2  -xO3 -xdepend     
-DVERSION=\"1.201\"  -DXS_VERSION=\"1.201\" -KPIC 
-I/usr/perl5/5.00503/sun4-solaris/CORE -Ddatadir="\"/ot/gimp/share\"" Lib.c
cc: Warning: option -2 passed to ld
"/opt/gnome/include/glib.h", line 1554: undefined or not a type: inline

The 3 includes paths: 

Are the ones I defined in CPPFLAGS.

I thought these would override the /opt/gnome/... includes. Or am I even
looking in the right direction? What might be missing to build the Perl plug-in?
Things to look at/for which give added info?

If you have any comments/guidance, I would appreciate.


Reply via email to