Agreed, but then we should disable the ability to set it from the switch.

On Sat, Sep 19, 2009 at 10:29 AM, Daniel Ng, Mr
<daniel...@mail.mcgill.ca> wrote:
> Why are we even allowed setting the subnet from the switch?  Isn't that what 
> we have a subnet element for?
>
> -----Original Message-----
> From: gini-devel-boun...@cs.mcgill.ca 
> [mailto:gini-devel-boun...@cs.mcgill.ca] On Behalf Of Alexis Malozemoff
> Sent: September 19, 2009 9:26 AM
> To: gini-devel@cs.mcgill.ca
> Subject: [Gini-devel] Fwd: [gini] gBuilder bug?
>
> The below problem is caused because no mask is set in the Switch.  We
> should set the default mask if none is set using the standard IP class
> system.
>
>
> ---------- Forwarded message ----------
> From: Julien Villemure <jvill...@cs.mcgill.ca>
> Date: Sat, Sep 19, 2009 at 12:06 AM
> Subject: [gini] gBuilder bug?
> To: g...@cs.mcgill.ca
>
>
> Hi,
>
> I'm running the latest stable version of GINI (from SVN) on Linux. I
> walked through the tutorial (from the help menu) successfully;
> everything works.
>
> However when I try to build a topology of my own, I am unable to compile
> it and gBuilder prints error messages. From an empty project, with the
> server running, I do the following:
>
> - Add a UML (UML_1)
> - Add a UML (UML_2)
> - Add a UML (UML_3)
> - Add a switch (Switch_1)
> - Set the subnet on the switch (to 192.168.5.0 but I doubt this matters)
> - Connect each UML to the switch
> - Click the "compile" button
>
> When trying to compile, the GINI log shows:
>     Auto-generate IP/MAC Addresses is ON.
>     Auto-routing is ON.
>
> However, the terminal window in which I started gbuilder shows the
> following:
>
> =================================================
> Traceback (most recent call last):
>   File "/home/teech/apps/gini/share/gbuilder/UI/MainWindow.py", line
> 434, in compile
>     xmlFile = compiler.compile()
>   File "/home/teech/apps/gini/share/gbuilder/Core/Compiler.py", line
> 70, in compile
>     self.compile_UML()
>   File "/home/teech/apps/gini/share/gbuilder/Core/Compiler.py", line
> 306, in compile_UML
>     self.writeInterface(uml, interface, mapping)
>   File "/home/teech/apps/gini/share/gbuilder/Core/Compiler.py", line
> 254, in writeInterface
>     elif not self.validate(prop, value, interface):
>   File "/home/teech/apps/gini/share/gbuilder/Core/Compiler.py", line
> 514, in validate
>     return self.valid_ip_subnet(value,
> interface[QtCore.QString("subnet")], interface[QtCore.QString("mask")])
>   File "/home/teech/apps/gini/share/gbuilder/Core/Compiler.py", line
> 586, in valid_ip_subnet
>     if mask_chunk[i] == "255":
> IndexError: list index out of range
> =================================================
>
> Since the topology cannot be compiled, I cannot start it. It should be
> noted that I followed the instructions given in Assignment 1 of COMP 535.
>
> Any help or insight would be appreciated.
>
> Thanks,
>
> Julien
> _______________________________________________
> gini mailing list
> g...@cs.mcgill.ca
> http://mailman.cs.mcgill.ca/mailman/listinfo/gini
> _______________________________________________
> gini-devel mailing list
> gini-devel@cs.mcgill.ca
> http://mailman.cs.mcgill.ca/mailman/listinfo/gini-devel
> _______________________________________________
> gini-devel mailing list
> gini-devel@cs.mcgill.ca
> http://mailman.cs.mcgill.ca/mailman/listinfo/gini-devel
>
_______________________________________________
gini-devel mailing list
gini-devel@cs.mcgill.ca
http://mailman.cs.mcgill.ca/mailman/listinfo/gini-devel

Reply via email to