For the auto-routing between 3 routers, an easier fix is just to compile twice, 
without disabling anything.  This was tested with auto-routing and auto-gen 
IP/MAC both enabled.
From: Alexis Malozemoff [EMAIL PROTECTED]
Sent: September 19, 2008 7:04 PM
To: Daniel Ng
Subject: Re: ssh on UMLs

SSH works.  You need to start sshd on the server.  The command is
/usr/sbin/sshd (you need the full path).

I've created the topology in parts 2 and 3 in GINI and it works fine.
You may need to fiddle around with saving the file and toggling route
computation, but in the end I've made it work.  Are you getting all
the "nexthop address not found" errors when compiling?  That's what I
got before, but randomly toggling the ip/mac and route generation
fixed it.  Maybe something we should fix in the next version...

For traceroute, I believe the issue is with the router.  Maybe the
professor can confirm this.

Also, is the password for the filesystem, just4now, documented
anywhere?  Should I send an e-mail to everyone in the class?
Otherwise, they can't really use SSH.


On Fri, Sep 19, 2008 at 5:28 PM, Daniel Ng <[EMAIL PROTECTED]> wrote:
> We tried ssh'ing between UMLs and this still doesn't work.  It seems that 
> assignment 1 will need this feature.  Is it going to be fixed?  We keep 
> getting the port 22: Connection refused error.
> Also, we ran into a strange bug when designing the second topology of the 
> assignment.  It seems that interconnecting 3 routers in a triangular shape 
> does not auto generate the routes properly.  It does most of the job, but a 
> few nexthop addresses were incomplete.  Fixing this in the code might be 
> tricky so I'm not sure if I can finish it over the weekend, but I'll give it 
> a try.  Fixing it manually is not hard.  We can just disable autorouting and 
> then fill in any incomplete (e.g. 192.168.1.) addresses.
> Another problem we ran into is using traceroute between 2 UMLs.  I vaguely 
> remember using traceroute with GINI before and it worked fine, but maybe that 
> was with the old router.  When we do traceroute now, it only gives us a bunch 
> of *s instead of addresses.  From reading the man pages, it seems that this 
> problem is usually the case when ttl for the packets is set too low.  Do you 
> know if this is because of the router?
gini mailing list

Reply via email to