Jakob Homan commented on GIRAPH-80:

+1.  We should avoid return whole lists in general. Iterators are more 
future-proof against the time when we'll be doing tricks to avoid running out 
of memory when working when huge, dense graphs.  The fewer implementation 
details we leak, the easier our lives will be.
> Don't expose the list holding the messages in BasicVertex
> ---------------------------------------------------------
>                 Key: GIRAPH-80
>                 URL: https://issues.apache.org/jira/browse/GIRAPH-80
>             Project: Giraph
>          Issue Type: Improvement
>    Affects Versions: 0.70.0
>            Reporter: Sebastian Schelter
> I'm currently trying to implement my own memory efficient vertex (similar to 
> LongDoubleFloatDoubleVertex) and ran into problems with getMsgList()
> This method returns a list pointing to the messages of the vertex and it is 
> modified externally (BasicRPCCommunications calls clear() and addAll() e.g.). 
> This makes it very hard to use something else than a java.util.List 
> internally (LongDoubleFloatDoubleVertex "hacked" around this) and it is 
> generally dangerous to have the internal state of an object be modified 
> externally. It also makes the code harder to read and understand.
> I'd suggest to change the API to let a vertex handle the modifications itself 
> internally (e.g. add something like pushMessages(...))

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
For more information on JIRA, see: http://www.atlassian.com/software/jira


Reply via email to