Pradeep Gollakota commented on GIRAPH-182:

Thanks for the review Jakob.
* I thought I removed the author tags. My IDE must have inserted it back in 
when I wasn't looking. I'll double check before submitting further patches.
* I agree that the name is a bit too verbose. An option could be to abbreviate 
part of the name. Maybe something like SimpleSeqFileVertexOF. I'll follow 
whatever convention that you guys want to introduce.
* I used X instead of M because M is used for message type and I wanted to 
distinguish it from that type. Since SequenceFileVertexInputFormat used X, I 
decided to use the same variable.
* Absolutely. I wasn't sure how to test the abstract class but I can definitely 
include a unit test for SimpleSequenceFileVertexOutputFormat. Any suggestions 
on how to test the abstract class?
> Provide SequenceFileVertexOutputFormat as an available OutputFormat
> -------------------------------------------------------------------
>                 Key: GIRAPH-182
>                 URL: https://issues.apache.org/jira/browse/GIRAPH-182
>             Project: Giraph
>          Issue Type: New Feature
>          Components: lib
>            Reporter: Pradeep Gollakota
>            Assignee: Pradeep Gollakota
>            Priority: Minor
>         Attachments: GIRAPH-182-1.patch
> SequenceFile's are heavily used in Hadoop. We should provide 
> SequenceFileVertexOutputFormat. Since SequenceFileVertexInputFormat is 
> already provided, it makes sense to also provide a mirroring OutputFormat

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
For more information on JIRA, see: http://www.atlassian.com/software/jira


Reply via email to