"Sean M. Burke" <[EMAIL PROTECTED]> writes:

> At 08:23 PM 2001-08-13 +0900, Keiichiro Nagano wrote:
> >[...]
> >I think LWP::UserAgent->simple_request should be divided into 2 parts.
> >First part modifies given HTTP::Request object according to
> >UserAgent's properties.  And second part simply send given
> >HTTP::Request object.  This has advantages as follows: [1] One can see
> >the real content of the request before actual requesting.  [2] One
> >(maybe a skilled user) can send his/her HTTP::Request object
> >untouched.  [3] Friendly for inheritance from LWP::UserAgent.
> That sounds like an okay idea to me.

Agree.  If you could redo your patch relative to perl5.5.53_96 that
would be great.

I suggest you rename 'real_request' as 'send_request'.


Reply via email to