Gitweb:     
http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=52e88f5d4a6b06f3a945728dd3bc403632afe069
Commit:     52e88f5d4a6b06f3a945728dd3bc403632afe069
Parent:     76598ebe081b04132f272440183e0aeb6507a079
Author:     Ingo Molnar <[EMAIL PROTECTED]>
AuthorDate: Fri Dec 29 16:47:10 2006 -0800
Committer:  Linus Torvalds <[EMAIL PROTECTED]>
CommitDate: Sat Dec 30 10:55:54 2006 -0800

    [PATCH] change WARN_ON back to "BUG: at ..."
    
    WARN_ON() ever triggering is a kernel bug.  Do not try to paper over this
    fact by suggesting to the user that this is 'only' a warning, as the
    following recent commit does:
    
      commit 30e25b71e725b150585e17888b130e3324f8cf7c
      Author: Jeremy Fitzhardinge <[EMAIL PROTECTED]>
      Date:   Fri Dec 8 02:36:24 2006 -0800
    
        [PATCH] Fix generic WARN_ON message
    
        A warning is a warning, not a BUG.
    
    ( it might make sense to rename BUG() to CRASH() and BUG_ON() to
      CRASH_ON(), but that does not change the fact that WARN_ON()
      signals a kernel bug. )
    
    i and others objected to this change during lkml review:
    
      http://marc.theaimsgroup.com/?l=linux-kernel&m=116115160710533&w=2
    
    still the change slipped upstream - grumble :)
    
    Also, use the standard "BUG: " format to make it easier to grep logs and
    to make it easier to google for kernel bugs.
    
    Signed-off-by: Ingo Molnar <[EMAIL PROTECTED]>
    Cc: Jeremy Fitzhardinge <[EMAIL PROTECTED]>
    Signed-off-by: Andrew Morton <[EMAIL PROTECTED]>
    Signed-off-by: Linus Torvalds <[EMAIL PROTECTED]>
---
 include/asm-generic/bug.h |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/include/asm-generic/bug.h b/include/asm-generic/bug.h
index a06eecd..14fae1f 100644
--- a/include/asm-generic/bug.h
+++ b/include/asm-generic/bug.h
@@ -35,7 +35,7 @@ struct bug_entry {
 #define WARN_ON(condition) ({                                          \
        typeof(condition) __ret_warn_on = (condition);                  \
        if (unlikely(__ret_warn_on)) {                                  \
-               printk("WARNING at %s:%d %s()\n", __FILE__,     \
+               printk("BUG: at %s:%d %s()\n", __FILE__,                \
                        __LINE__, __FUNCTION__);                        \
                dump_stack();                                           \
        }                                                               \
-
To unsubscribe from this list: send the line "unsubscribe git-commits-head" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to