Gitweb:     
http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=bbdfff86a8f0c91ad8b6dedf74bc14de4ba39679
Commit:     bbdfff86a8f0c91ad8b6dedf74bc14de4ba39679
Parent:     705962ccc9d21a08b74b6b6e1d3cf10f98968a67
Author:     Gabriel Mansi <[EMAIL PROTECTED]>
AuthorDate: Mon May 7 18:55:13 2007 -0300
Committer:  Dave Jones <[EMAIL PROTECTED]>
CommitDate: Sun May 13 17:41:47 2007 -0400

    [AGPGART] Fix wrong ID in via-agp.c
    
    there is a wrong id in drivers/char/agp/via-agp.c
    #define PCI_DEVICE_ID_VIA_CX700         0x8324
    It must be 0x0324
    
    Notice that PCI_DEVICE_ID_VIA_CX700 is also used in
    drivers/i2c/busses/i2c-viapro.c and
    drivers/ide/pci/via82cxxx.c
    
    So, I think that constant must be renamed to avoid conflicting.
    I attached a proposed patch.
    
    Signed-off-by: Dave Jones <[EMAIL PROTECTED]>
---
 drivers/char/agp/via-agp.c |    6 +++---
 include/linux/pci_ids.h    |    1 +
 2 files changed, 4 insertions(+), 3 deletions(-)

diff --git a/drivers/char/agp/via-agp.c b/drivers/char/agp/via-agp.c
index a2bb4ec..9aaf401 100644
--- a/drivers/char/agp/via-agp.c
+++ b/drivers/char/agp/via-agp.c
@@ -384,9 +384,9 @@ static struct agp_device_ids via_agp_device_ids[] 
__devinitdata =
                .device_id      = PCI_DEVICE_ID_VIA_P4M800CE,
                .chipset_name   = "VT3314",
        },
-       /* CX700 */
+       /* VT3324 / CX700 */
        {
-               .device_id  = PCI_DEVICE_ID_VIA_CX700,
+               .device_id  = PCI_DEVICE_ID_VIA_VT3324,
                .chipset_name   = "CX700",
        },
        /* VT3336 */
@@ -540,7 +540,7 @@ static const struct pci_device_id agp_via_pci_table[] = {
        ID(PCI_DEVICE_ID_VIA_83_87XX_1),
        ID(PCI_DEVICE_ID_VIA_3296_0),
        ID(PCI_DEVICE_ID_VIA_P4M800CE),
-       ID(PCI_DEVICE_ID_VIA_CX700),
+       ID(PCI_DEVICE_ID_VIA_VT3324),
        ID(PCI_DEVICE_ID_VIA_VT3336),
        ID(PCI_DEVICE_ID_VIA_P4M890),
        { }
diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
index ccd85e4..3b1fbf4 100644
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
@@ -1288,6 +1288,7 @@
 #define PCI_DEVICE_ID_VIA_8363_0       0x0305
 #define PCI_DEVICE_ID_VIA_P4M800CE     0x0314
 #define PCI_DEVICE_ID_VIA_P4M890       0x0327
+#define PCI_DEVICE_ID_VIA_VT3324       0x0324
 #define PCI_DEVICE_ID_VIA_VT3336       0x0336
 #define PCI_DEVICE_ID_VIA_8371_0       0x0391
 #define PCI_DEVICE_ID_VIA_8501_0       0x0501
-
To unsubscribe from this list: send the line "unsubscribe git-commits-head" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to