Gitweb:     
http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=d8af7c6ab0bc4e2404f290801982b40223a97408
Commit:     d8af7c6ab0bc4e2404f290801982b40223a97408
Parent:     b7076156af7a87799c0e425db5aec8378be1c3ea
Author:     Robert P. J. Day <[EMAIL PROTECTED]>
AuthorDate: Fri Oct 19 23:13:32 2007 +0200
Committer:  Adrian Bunk <[EMAIL PROTECTED]>
CommitDate: Fri Oct 19 23:13:32 2007 +0200

    Drop the superfluous test for an old version of gcc.
    
    The header file <linux/compiler.h> already enforces a suitably recent
    version of gcc, so there's no point checking for that again.
    
    Signed-off-by: Robert P. J. Day <[EMAIL PROTECTED]>
    Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]>
---
 init/main.c |    8 --------
 1 files changed, 0 insertions(+), 8 deletions(-)

diff --git a/init/main.c b/init/main.c
index 0dd0e7a..ea0f725 100644
--- a/init/main.c
+++ b/init/main.c
@@ -70,15 +70,7 @@
 /*
  * This is one of the first .c files built. Error out early if we have compiler
  * trouble.
- *
- * Versions of gcc older than that listed below may actually compile and link
- * okay, but the end product can have subtle run time bugs.  To avoid 
associated
- * bogus bug reports, we flatly refuse to compile with a gcc that is known to 
be
- * too old from the very beginning.
  */
-#if (__GNUC__ < 3) || (__GNUC__ == 3 && __GNUC_MINOR__ < 2)
-#error Sorry, your GCC is too old. It builds incorrect kernels.
-#endif
 
 #if __GNUC__ == 4 && __GNUC_MINOR__ == 1 && __GNUC_PATCHLEVEL__ == 0
 #warning gcc-4.1.0 is known to miscompile the kernel.  A different compiler 
version is recommended.
-
To unsubscribe from this list: send the line "unsubscribe git-commits-head" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to