Gitweb:     
http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=b523381e325366cc54a2548df418c2a427b2f2ee
Commit:     b523381e325366cc54a2548df418c2a427b2f2ee
Parent:     cb1042f285c2168bd8cf10aca0e24802e682252b
Author:     James Bottomley <[EMAIL PROTECTED]>
AuthorDate: Fri Jan 18 17:47:56 2008 -0600
Committer:  James Bottomley <[EMAIL PROTECTED]>
CommitDate: Wed Jan 23 11:29:34 2008 -0600

    [SCSI] fix pcmcia compile problem
    
    This patch
    
    commit 8ae732a91df051aba6820068a47b631a06599d84
    Author: Tejun Heo <[EMAIL PROTECTED]>
    Date:   Fri Dec 7 22:36:23 2007 +0900
    
        [SCSI] make pcmcia directory use obj-y|m instead of subdir-y|m
    
    Moved the scsi Makefile into conformance, but also caused the pcmcia
    subdirectory to get built in for the first time, leading to duplicate
    symbols in an allyesconfig build.  Since evidently no-one relies on
    these being built in, fix this by ensuring they can only be built as
    modules.
    
    Acked-by: Tejun Heo <[EMAIL PROTECTED]>
    Signed-off-by: James Bottomley <[EMAIL PROTECTED]>
---
 drivers/scsi/pcmcia/Kconfig |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

diff --git a/drivers/scsi/pcmcia/Kconfig b/drivers/scsi/pcmcia/Kconfig
index fa481b5..53857c6 100644
--- a/drivers/scsi/pcmcia/Kconfig
+++ b/drivers/scsi/pcmcia/Kconfig
@@ -6,7 +6,8 @@ menuconfig SCSI_LOWLEVEL_PCMCIA
        bool "PCMCIA SCSI adapter support"
        depends on SCSI!=n && PCMCIA!=n
 
-if SCSI_LOWLEVEL_PCMCIA && SCSI && PCMCIA
+# drivers have problems when build in, so require modules
+if SCSI_LOWLEVEL_PCMCIA && SCSI && PCMCIA && m
 
 config PCMCIA_AHA152X
        tristate "Adaptec AHA152X PCMCIA support"
-
To unsubscribe from this list: send the line "unsubscribe git-commits-head" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to