I already have cloned an SVN repository using git-svn. But now a new
directory has appeared in the SVN repo which are outside of the
standard directories - trunk, branch, and tag. To track directory I
manually added the following to my .git/config file:

[svn-remote "new_dir"]
        url = http://path/to/my/repo/root
        fetch = relative/path/to/new_dir:refs/remotes/new_dir

And when I ran 'git svn fetch new_dir', it gave a couple of errors in
the beginning, with the usual consolation messages. But it didn't
actually do any fetches, and the new_dir branch isn't present in 'git
branch -a'. If I run the command again, it is silent and does nothing.

Isn't what above the right configuration? Could somebody point out
what's wrong here?


You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to