I spent almost 6 hours on this and a hero named Ilari on 
solved it in 30 seconds.  The key is that gitosis-init works only
once.  I wish that the manual had pointed that out.  The hero
recommended that I check out Gitolite.  Thank you !

On Feb 12, 9:55 am, Vincent P <ease...@gmail.com> wrote:
> Please help: gitosis-init does not seem to add my laptop public key to
> the git account on the repository server at all.
> After copying my laptop public key to /tmp on the server, I run the
> following command on the server:
> sudo -H -u git gitosis-init < /tmp/id_dsa.pub
> I get the expected
> Reinitialized existing Git repository in /var/gitosis/repositories/
> gitosis-admin.git/
> Reinitialized existing Git repository in /var/gitosis/repositories/
> gitosis-admin.git/
> then I did this:
> sudo chmod 755 /var/gitosis/repositories/gitosis-admin.git/hooks/post-
> update
> But when I run the following commands on the server to see if my
> laptop public key has been added, it's not there:
> sudo ls /var/gitosis/repositories/gitosis-admin.git/gitosis-export/
> keydir
> sudo gedit /var/gitosis/.ssh/authorized_keys
> I can ssh to the server from the laptop but when I try to git clone
> g...@server.local:gitosis-admin.git, I get "Permission denied
> (publickey)", which makes sense because my laptop public key is not in
> gitosis-export/keydir nor gitosis/.ssh/authorized_keys.
> I suspect that gitosis-init has failed to put my laptop public key in
> those two places.  What should I do?
> Thanks much.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-us...@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to