I downloaded a bundle which I cloned from.
Unfortunately the person who made the bundle had made some unstaged
I tried to pull, but it gave me an error about the changes
So i used git reset --hard and I tried to pull again and got the exact
same error.. (Git diff also shows the files are edited, presumably by
the guy who made the bundle)

The GIT GUI showed 3 files which had 'unstaged' changes (the files
which caused the aforementioned error in the shell. So I reverted the
changes from within the GUI and the list of files with changes now
became empty..

So I quit the GIT GUI and restarted it again, only to see the same 3
files back on the list, with the changes somehow 'unreverted'
I modified the folder preferences in Windows explorer and removed the
'Read only' option

Tried reverting again, still the files come back with the same

Also tried in GIT Bash :

git checkout .  (dot)

and seperately,

git reset --hard

Still doesn't work

For some reason GIT is not able to revert changes to files
permanently ..
What might be the reason?

Please help!

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-us...@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to