Unfortunately the git binary on the machine that I'm using does not
have git-svn (e.g. SVN/Core.pm and friends). I already tried to
install binaries, but got all sorts of .so version mismatch errors.
Hence I tried to go the source route. If you know a git-svn binary
which works with perl  v5.8.5 and svn 1.6.9 (RHEL4) I would be very

I've already tried the description given in larrytheguid, But whenever
I try to run git-svn I get:

libsvn_swig_perl-1.so.0: undefined symbol: PL_sv_undef at /usr/lib/
perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm line 230.

It seems like my local perl installation uses the local DynaLoader.pm
rather than the one in its installation (which is 5.12.3). The problem
is probably related to perl picking up wrong libraries. However
running perl -V gives a @INC list showing only my local installation.

http://svn.haxx.se/dev/archive-2008-02/0705.shtml says that one should
use -lsvn_swig_perl-1 in the LIB variable which causes missing

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to