2011/6/20 Konstantin Khomoutov <flatw...@users.sourceforge.net>:
> On Sun, 19 Jun 2011 09:21:05 -0300
> Vinicius Massuchetto <viniciusmassuche...@gmail.com> wrote:
>> Please let me know if this is not the right place for this kind of
>> support.
> I don't think so.
> It appears to be more suitable for a Debian bug tracker.

It seems to be. Thanks for helping.

>> On Debian squeeze, I'm getting the syslog error:
>>     unable to allocate any listen sockets on host (null) port 9418
> What action does produce this error?

When I run:
$sv start git-daemon

>> And I can't clone remotely, also.
> Do you mean you're unable to use `git clone` to fetch data from the host
> running that strangely behaiving git-daemon instance?

Exactly. It gives a connection error.

> Then what does "also" mean here?

That I'm relating this error from the fact that I can't clone remotely.

>> The file `/etc/service/git-daemon/run` contains the following:
>>     "$(git --exec-path)"/git-daemon --verbose
>> --base-path=/var/cache/git --detach --syslog --reuseaddr --export-all
>> `netstat -l | grep git` outputs this:
>>     tcp        0      0 *:git                   *:*
>>     tcp6       0      0 [::]:git
>> [::]:*                  LISTEN
>> I'm currently restarting services with the `sv start/stop` command
>> line, and killing service process to ensure it got reloaded.
> I don't understand the meaning of this sentence--are you claiming that
> restarting the git-daemon service fixes the problem?
> Does it fixe the problem temporarily?  Does not fix it at all?

No. It doesn't fix anything. Sorry for not saying that my
understanding of this syslog error is that another git-daemon instance
is already running on port 9418, as netstat says. That's why I tried
to kill it.

So, both of these actions will log this message into syslog:
$sv stop git-daemon; sv start git-daemon
$kill -9 <git daemon pids>

>> Maybe I'm missing something really stupid.
>> Any help is much appreciated.
> Your message unfortunately misses an exact problem statement.
> Instead, there's a bunch of assorted symptoms with no connections
> between them explained.

Sorry for that. It seems so logic to me that I forgot to write. =D

> In the mean time I can propose two solutions:
> 1) Do not use git-daemon and use SSH access for pulling data.
>   Reasoning: git-daemon is strictly read-only, so when you will decide
>   to push to your repository, you'll have to use SSH or some other
>   method anyway.  That is, git-daemon is only good for publicly-visible
>   hosting (like github etc) when you expect that 99.9% of accesses
>   will be fetching data.

That's exaclty what I need.

> 2) Try running git-daemon from inetd.  Note that in order for this to
>   work you surely should not have the daemon running.

You got any suggested link or configuration set for this?

Thanks again.
Vinicius Massuchetto

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to