I have a weird problem I cannot seem to resolve despite googling
around and playing with this for a few hours ...

I have local OS X machine which I use for dev & I push my git
repository to a remote Ubuntu server. I had all this setup and it has
been working fine for month. I connect to the remote server via ssh
and use a proprietary port.

All of a sudden, after not pushing changes for a week or so, when I
tried to push some new changes I got a hangup response during the
push. From now on I simply cannot push anything to the remote server.
I either get a hang where the push waits indefinitly, or sometimes,
intermittently,  I get a:

ssh_exchange_identification: read: Connection reset by peer
fatal: The remote end hung up unexpectedly

response. I tried to push with the -f option and also rebooted both
machines. Note that simply using ssh directly to the remote server
works fine. Seems like git has been left in some state where it cannot
recover from to restart the push (but that us just a guess of mine).

Any ideas or suggestions how to get out of this state?

Thanks, Harry

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to