On Tue, Oct 04, 2011 at 03:53:09PM -0700, Dean Schulze wrote:

> I can't get the git daemon to start on Ubuntu 11.04 64-bit. I've followed 
> these instructions
> https://help.ubuntu.com/community/Git
> but nothing runs on port 9418.
It's hard to tell anything because that page lists at least two distinct
ways to make git-daemon serve requests.

First, it worth considering this question: do you really need to run
git-daemon at all?  The only task git-daemon does is providing
*anonymous and read-only* access to a repository, so its only really
useful for things like serving code of a free software project to a
general public, and this task is anyway better handled with a dedicated
specialized resource like github, google code, SF.net etc.

Second, if you do really need git-daemon, I would pick one of these
ways, in this order:
1) Use inetd/xinetd.  I tried to run git-daemon under openbsd-inetd
   (which seems to be the default inetd implementation in Debian) and it
   worked OK.  You appear to be in need to read some docs on what that
   inetd thing is upfront, that is, before copying and pasting some
   example from some wiki.  When debugging an inetd service, look into
   /var/log/daemon.log for messages.
2) Install git-daemon-run package which seems to be happily borrowed by
   Ubuntu so there's a good chance it'll just work.

> Do I have to have a 64-bit version of git for a 64-bit OS?
In any case this has nothing to do with your problem as Git is a
native package and supposedly you have the correct version as with any
other package in the distro.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to