On Jan 18, 11:14 pm, Thomas Ferris Nicolaisen <tfn...@gmail.com>
> Also make sure you readhttp://book.git-scm.com/5_submodules.html- and
> maybe try to do something like the simple example 
> here:http://help.github.com/submodules/
Thanks, the github link helped. I tried to follow the instructions of
the previous link when first setting up submodules, though it does not
mention how to set up submodules for remote repositories. I now
removed the submodule and added it with the link to the remote
repository. But the question how I can push my previous commits
remains. Therefore, I did the following in the discarded working
$git format-patch -2 --stdout > ~/Desktop/cf.patch
Next I tried to apply the two commits to the newly set up submodule:
$ git am ~/Desktop/cf.patch
But ended up with an error message, where a few lines end with ".git/
rebase-apply/patch:LINE_NUMBER: trailing whitespace." and last there
is an "error: patch failed: somefile:11
error: somefile: patch does not apply"
When I check the status afterwards, nothing has changed and git am --
resolve complains, because nothing has changed. I could not find an
explanation for this error.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to