I have  shared hosting account with godaddy. I am trying  to install

I have followed the following steps from the following URL


1. I have ssh setup and I can access. for example my FTP login name is
ftpuser if I try ssh ftpu...@mydomain.com  no issues and it is
working. ~/.bashrc is executed perfectly

2. I have downloaded latest binary (git-  )
from  http://pkgs.repoforge.org/git/   and installed as per

mkdir ~/opt && cd ~/opt
rpm2cpio ~/git-  | cpio -id
~/opt/usr/bin/git --version
git version 1.7.8

3. I have configured /.bashrc with the following

export PATH


4. I have verified as per below steps and it is working on the shared

 mkdir ~/testrepo
cd ~/testrepo
echo 'This is a test' > README.txt
git init
warning: templates not found /usr/share/git-core/templates
Initialized empty Git repository in /home/content/XX/YYYYYYY/git/.git/
git add README.txt
git commit -m 'initial version'
[master (root-commit) 5214f3b] initial version
 1 files changed, 1 insertions(+), 0 deletions(-)
 create mode 100644 README.txt

5. But I am unable to clone from the shared host to my local PC

I have tried to the following commands

a) git clone ssh://ftpu...@118.139.xxx.5/~/git/Read me.txt
   (note xxx) is changed for privacy reasons.

I get the following error message

Cloning into Readme.txt...
fatal: Invalid gitfile format: /var/chroot/home/content/85/91334343/
fatal: The remote end hung up unexpectedly

b) So I have followed the following steps


and created a config file

$ cd ~/.ssh
$ vi config
# Put the following in your config file change "myhost" and "myid"
with your
# GoDaddy host and userid
Host myHostAlias
HostName 118.139.xxx.5
User ftpuser
IdentityFile ~/.ssh/myid@goDaddy

doubt: I have used IdentityFile as follows
IdentityFile  ~/.ssh/id_rsa

This id_rsa file is located on my local PC . Is the steps correct for
IdentityFile and Host, Hostname, User?

when I tried the following command, it works (I could able to login)

ssh myHostAlias

but  I am not sure how to clone?
When i tried the following

git clone -u  /var/chroot/home/content/85/91334343/git/Readme.txt
Cloning into myHostAlias...
/var/chroot/home/content/85/91334343/git/Readme.txt  '/home/rams/
domain/git/test/myHostAlias': 1: /var/chroot/home/content/85/91334343/
git/Readme.txt: not found
fatal: The remote end hung up unexpectedly

I am struck. What is causing the problem?

Thank you in advance.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to