I am having the same problem.
I tried everything, modified all configs from git but still with error. 
I also tried to make another repository with size greater than 210 MiB and 
it's still with the same problem.
>From one unix to another both repositories works like charm. I tested and 
it is not a time-based problem.
It seems that git for windows has a problem with transfers larger than 200 
MiB (clone, push, pull, etc) with this out of memory leak.
Please help ! 

Thank you in advance,
Tudor Vasinca


On Wednesday, July 11, 2012 10:28:19 AM UTC+3, Sergiu wrote:
>
> Hi.
>  
> I've been struggling for few days now with this, so I was hoping I could 
> get some suggestions here.
> It's about cloning a repo. It used to work, but it just started to throw 
> this error when I "git clone ssh://git@hostname:10101/test.git":
>
> remote: Counting objects: 11401, done.
> remote: Compressing objects: 100% (9278/9278), done.
> select: Not enough memory4561/11401), 206.60 MiB | 1.01 MiB/s
> fatal: The remote end hung up unexpectedly
> fatal: early EOF
> fatal: index-pack failed
>
> I cannot clone this repo anymore. It always dies around 206-208 MiB. 
> Anyone dealt with this before? Any suggestions? Thank you.
>
> # Server: CentOS release 6.2 (Final) 2.6.32-220.el6.x86_64
> # cat /proc/meminfo
> # MemTotal:       16316936 kB (16 316 936 kilobytes = 15.5610428 gigabytes)
> # MemFree:         5251088 kB (5 251 088 kilobytes = 5.00782776 gigabytes)
>
>
>

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To view this discussion on the web visit 
https://groups.google.com/d/msg/git-users/-/nW08VxduCDcJ.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
git-users+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/git-users?hl=en.

Reply via email to