On Tue, 7 Aug 2012 18:24:48 -0700 (PDT)
Lisa Zorn <lisa.z...@sfcta.org> wrote:

(CC'ing the msysgit mailing list, I suspect the discussion does really
belong there, so possibly please cull git-users from the CC list when

> I have been using git for years and have not run into this problem
> before. I tried to git clone a repo that's on a local drive, and I
> get this error: dir1\dir2>git clone -b master Y:\git_src
> Cloning into 'Muni_GenevaBRT_HuntersPtToCandlestickInterchangeOnly'...
> done.
> fatal: unable to overwrite old ref-pack file: Permission denied
> fatal: The remote end hung up unexpectedly
> However, when I run it in another directory (not a subdir of dir1),
> it works fine.  But it's repeatable; if I run it from dir1\dirX it
> happens again.
> I am using the stable version of git, and I'm on windows.  What's
> going on with the "old ref-pack file"?

Are you sure that the combination of "dir1\dir2" and that "Muni_..."
thing does not exceed the limit of 260 or so characters?

This has been discussed recently: [1], [2].

I would try to debug this situation by monitoring which files are acce
ssed by Git tools using Process Monitor [3] (ex. FileMon) -- you could
filter its output by failed attempts to create/open files.

1. https://github.com/msysgit/msysgit/issues/52
2. http://thread.gmane.org/gmane.comp.version-control.msysgit/14572
3. http://technet.microsoft.com/en-us/sysinternals/bb896645

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to