I hope you can help me.

We have git version installed, but it does not support http/https, 
it must not have been built with curl.

I am trying to install version with curl support so we can use the 
http protocol. 

I am running on SLES 10.x Kernel


I am trying to do a make all, I’m getting the following error:





    CC xdiff/xpatience.o

    CC xdiff/xhistogram.o

    AR xdiff/lib.a

    LINK git-credential-store

skipping incompatible /usr/lib/libz.so when searching for -lz

skipping incompatible /usr/lib/libz.a when searching for -lz

cannot find -lz

collect2: ld returned 1 exit status

make: *** [git-credential-store] Error 1


I’m not sure how to resolve this library problem; do I just need a newer 
version of libz?


Any help would be greatly appreciated.




You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To view this discussion on the web visit 
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to