Is your remote a 'bare' repository, or does it have a working directory? -- I 
ask because you say you are working on the branch on both sides. 

It is normal to have your remote as a 'bare' repo, though you can manage if 
both are 'working' but in such cases you would use different branches on the 
repos so that you won't loose data.
  ----- Original Message ----- 
  From: kramer.newsreader 
  Sent: Monday, November 05, 2012 9:59 PM
  Subject: Re: [git-users] Unable to push

  Here you go.  I've anonymized checkin messages, domains, etc.

  By the way, I am *attempting* to work on the nov2012 branch both locally and 

  $ git branch -avv
    master                     f645170 Fix over_18 parameter. See #19010
  * nov2012                    7fc7d04 [origin/nov2012] Little more javadoc
    ticket/15734               251a314 Adding support for ...
    ticket/17513               5251a79 Updated ...
    tmp_branch                 3f4b7bd Fixed ...
    remotes/origin/HEAD        -> origin/master
    remotes/origin/master      9ecfb22 Support for ...
    remotes/origin/mojiva      71ef51a Fix ...
    remotes/origin/nov2012     7fc7d04 Little more javadoc
    remotes/origin/test        a2b09e8 Recalculate ...
    remotes/origin/test-branch 443339d Fix ...
  $ git remote -vv
  gerrit    ssh://<user>@gerrit.<domain>:29418/<project> (fetch)
  gerrit    ssh://<user>@gerrit.<domain>:29418/<project> (push)
  origin    ssh://git@git.<domain>/<project> (fetch)
  origin    ssh://git@git.<domain>/<project> (push)

  On Monday, November 5, 2012 4:52:06 PM UTC-5, Alexandru Pătrănescu wrote:
    maybe you have multiple remotes and you pull from one and try to push to 
    show us as possible an output from:
    git branch -avv

    git remote -vv

    On Monday, November 5, 2012 11:33:06 PM UTC+2, kramer.newsreader wrote:
      Yeah that's what I would figure, but it isn't the case.  Git status shows 
no conflicts.  

      I did a git pull(and did pull in a change or two that was made since my 
last post here).  Git status still showed no conflicts, so I tried a push 
again, but got the same error.

      On Monday, November 5, 2012 3:58:22 PM UTC-5, William Mizuta wrote:
        Is there conflicts in your repository? What is the result of a git 

        If there is no conflicts, I think that someome pushed new commits and 
you need to do a git pull --rebase again.

        William Seiti Mizuta

        Desenvolvedor da Caelum

        On Mon, Nov 5, 2012 at 6:54 PM, kramer.newsreader 
<> wrote:

          Frustrated new git user here...

          Anyway, I have some changes that I would like to push but am unable I 
get the following error:

          error: failed to push some refs to 'ssh://git@<...>'
          To prevent you from losing history, non-fast-forward updates were 
          Merge the remote changes (e.g. 'git pull') before pushing again.  See 
          'Note about fast-forwards' section of 'git push --help' for details.

          Okay, so if I am translating git's terminology back to human 
language, I believe that this is telling me that I cannot push because I would 
lose history.  My change is not downstream of where the head is.

          The thing is that I just did a successful git pull -rebase, so my 
changes should be right on top of the head.  I can confirm that by attempting 
another pull:

          JohnKramer-2:statistics jkramer$ git pull --rebase
          Current branch nov2012 is up to date.

          What's going on here?



  No virus found in this message.
  Checked by AVG -
  Version: 2013.0.2742 / Virus Database: 2617/5874 - Release Date: 11/04/12


Reply via email to