I'm trying to add git functionality to a production CentOS 5.5 system that 
has no development tools (since it is a production system). So I don't have 
access to make/gcc/etc. I basically want to install Git to be able to 
easily & quickly synchronize a website dir with my Git repo, so I have no 
need for compiling any source files.

I do not have root access, and for obvious reasons, root is does not want 
to install Git on a prod system, but is okay if I can set it up locally for 
my own use.

I've tried to download and unpack a git-core.rpm into my home dir and 
although I am able run some functionality of git, none of git's 
dependencies are where it expects them and so it fails.

My structure looks like the following:


When I run something like git help clone, I get an error msg No manual 
entry for git-clone. This is confirmed by git --man-path (/usr/share/man). 
Other commands fail similarly.

How can I tell git to use ~/git as the root instead of / as the root to all 
git dependencies without recompiling? I cannot seem to find any environment 
vars or git vars that I can set.




Reply via email to