I am trying to push a change to a remote server and running into "change 
closed "error,thats because the change-id am
trying to push is same as an earlier change that was already pushed(dont 
know why its same),I trid to generate a new commit
message using the .git/hook,it generates a new commit-msg but my change-id 
is still the same and I cant push still,
any inputs on why a new change-id is not being generated?

    <username:promt>git push 
    Counting objects: 1852, done.
    Delta compression using up to 8 threads.
    Compressing objects: 100% (688/688), done.
    Writing objects: 100% (809/809), 1.37 MiB, done.
    Total 809 (delta 678), reused 177 (delta 95)
    remote: Resolving deltas: 100% (678/678)
    remote: Processing changes: refs: 1, done    
     ! [remote rejected] HEAD -> refs/for/master (change 219386 closed)
    error: failed to push some refs to 

Tried to generate a change id using below

    cd .git/hooks
    scp -p -P 29418 usern...@repo.company.com:hooks/commit-msg .
    cd ../..


Reply via email to