wow i just realized you posted this in 2009 @_@
the solution is to fix the permissions in the actual repository folder (on 
the server). since we are using gitosis, the repository (and ALL 
subfolders/subfiles) must belong to the git user. do something like...

# chown -R git:git gitosis-admin.git/

hope this helps anyone else who runs into this thread! especially people 
who need help in 2019 ;)

On Monday, January 21, 2013 3:45:33 AM UTC-5, robertgenito wrote:
> i wish i knew. gitosis makes me sad sometimes...
> On Tuesday, March 17, 2009 12:10:33 PM UTC-4, gte351s wrote:
>> I'm trying to set up gitosis on my office server, but ran into some 
>> problems when I tried to push changes. 
>> Setup went fine, and I was able to clone gitosis-admin.git repository. 
>> When I tried adding a user to gitosis.conf and push the changes I got 
>> this error: 
>> error: unable to create temporary sha1 filename ./objects/26: 
>> Permission denied 
>> fatal: failed to write object 
>> error: unpack failed: unpacker exited with error code 
>> To git@gitserver:gitosis-admin.git 
>> ! [remote rejected] master -> master (n/a (unpacker error)) 
>> error:  failed to push some refs to 'git@gitserver:gitosis-admin.git' 
>> Anyone knows what's up?


Reply via email to