On Wed, 13 Feb 2013 15:49:56 +0200
Gabby Romano <omerik...@gmail.com> wrote:

> I did try 3 things :
> 
> 1) changed git path to full path under the git plugin in jenkins.
> didn't help.
> 2) I tried to ssh manually from the master (and from the slave which
> actually runs the jobs, in fact), it worked with no password asked,
> so I guess the ssh configuration is correct.
> 3) I also tried to clone manually (using the ssh URL) from the
> repository server, running as the user who runs jenkins - worked fine.
> 
> I ran out of ideas.....:-(
> 
> did I miss something here ?

One another idea to investigate is some possibility for your ssh client
reading some other file with known hosts, differing from that it reads
when you run ssh (or git) by hand.  I'm not sure about how *exactly*
this might happen, but at least it looks like this.

To find out, try running the whole fetch operation using the `strace`
tool passing it the "-f" command-line option (stands for "forks") and
possibly further instrument it to only trace open(2) calls and write
its output to a log file.  So, do something like:

$ strace -o /tmp/fetch.log -f -e trace=open jenkins fetch blah

Then in the log file, try to see which files were open(2)-ed by the
toolchain -- the suspects are files named like "known_hosts" or accessed
using paths containing ".ssh" in them.

Also plain googling using
https://www.google.ru/search?q="Host+key+verification+failed"+jenkins
yields a whole lot of discussions; since I have almost zero information
about your setup, you're advised to dig through them by yourself and
see if something applies to your case.

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to