On Wednesday, February 13, 2013 2:49:56 PM UTC+1, Gabby Romano wrote:

> Thanks Konstantin and All, 
> I did try 3 things : 
> 1) changed git path to full path under the git plugin in jenkins. didn't 
> help.
> 2) I tried to ssh manually from the master (and from the slave which 
> actually runs the jobs, in fact), it worked with no password asked, so I 
> guess the ssh configuration is correct.
> 3) I also tried to clone manually (using the ssh URL) from the repository 
> server, running as the user who runs jenkins - worked fine.
Then Jenkins (or rather the slave) must be doing SSH differently somehow. 
I've fiddled a lot with this, but mostly with Windows slave nodes (I take 
it you are working with Linux machines only since it is using /usr/bin/git).

Where are the keys located?

A thing you can try is to make a "Debugger Job" in Jenkins. 

1) Make a free-style job that just does the following (no SCM configured):
2) Add build step -> Execute Shell
3) Enter the following:

ssh -vvv git@<git server url>

Now run the job and observe the console output. You should be able to see 
where SSH tries looking for the key files.

Note that there's no guarantee that the Jenkins Git plugin uses SSH exactly 
the same way, but there could be some clues here.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to