I am getting error while pushing the already committed source. 
LDAP authentication is configured for user management. 

Note: This was working fine all these days and suddenly without any changes 
in the configuration settings, there was error noticed!

*Error scenario - It does not even ask the user name and password.*

[root@imsgit imstest_ldap]# export GIT_CURL_VERBOSE=1
[root@imsgit imstest_ldap]# git status
# On branch master
nothing to commit, working directory clean
[root@imsgit imstest_ldap]# ls -l
total 4
-rw-r--r-- 1 root root 111 Feb 25 12:08 sysInfo.txt
[root@imsgit imstest_ldap]#
[root@imsgit imstest_ldap]# git push
* Couldn't find host in the .netrc file; using defaults
* About to connect() to port 8080 (#0)
*   Trying * connected
* Connected to ( port 8080 (#0)
> GET /git/imstest_ldap.git/info/refs?service=git-receive-pack HTTP/1.1
User-Agent: git/
Accept: */*
Accept-Encoding: gzip
Pragma: no-cache

* The requested URL returned error: 403
* Closing connection #0
error: The requested URL returned error: 403 while accessing
fatal: HTTP request failed
[root@imsgit imstest_ldap]#

*Apache logs are capturing the below texts*

==> error_log <==
[Mon Feb 25 12:10:34 2013] [error] [client] Service not 
enabled: 'receive-pack'

==> access_log <== - - [25/Feb/2013:12:10:34 +0530] "GET 
/git/imstest_ldap.git/info/refs?service=git-receive-pack HTTP/1.1" 403 - 
"-" "git/"

*Below are the LDAP configuration*

[root@imsgit httpd]# cat /etc/httpd/conf.d/git.conf
<VirtualHost imsgit.apac.nsn-net.net:8080>

   ServerName imsgit.apac.nsn-net.net
   DocumentRoot /imsgit/Repositories

   SetEnv GIT_PROJECT_ROOT /imsgit/Repositories
   ScriptAlias /git/ /usr/local/libexec/git-core/git-http-backend/

   <Location /git/imstest_1>
       AuthType Basic
       AuthName "GIT repository"
       AuthUserFile /imsgit/conf/users-imstest_1
       Require valid-user

   <Location /git/imstest_ldap.git>
       AuthType Basic
       AuthName "Git Authentication; Login with your LDAP user id and pwd"
       AuthBasicProvider ldap
       AuthzLDAPAuthoritative off
       AuthLDAPURL "<<Valid URL>>"
       AuthLDAPBindDN "<<Valid Bind DN>>"
       AuthLDAPBindPassword "<<Valid Pwd>>"

[root@imsgit httpd]#

Any help on this is highly appreciated. Thanks in advance...

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to