I committed some changes to my repository at home and then I tried to pull 
them at my work and I got the following message

There is no tracking information for the current branch.
Please specify which branch you want to merge with.
See git-pull(1) for details.
  git pull <remote> <branch>
If you wish to set tracking information for this branch you can do so with:
  git branch --set-upstream master origin/master

Naturally I tried to run git branch --set-upstream master origin/master 
And here is what I got when I ran it
The --set-upstream flag is deprecated and will be removed. Consider using 
--track or --set-upstream-to
Branch master set up to track remote branch master from origin.

Since this option will be removed I decided to it "the modern" way using 
--track. Here is what I got
after running git branch --track master
fatal: A branch named 'master' already exists.

After this error I decided to use --set-upstream-to option. Here is what I 
got after running git branch --set-upstream-to=master
warning: Not setting branch master as its own upstream.

Then I ran git pull and everything worked. I suspect it worked because of 
--set-upstream deprecated. Can someone explain what have I done
wrong with --track and --set-upstream-to options? Any help is appreciated.

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to