I am using Bitbucket and I am able to connect via my local server (my comp 
is windows 7) and I am doing push,pull,merge and other things.Great!
I have an Amazon EC2 Ubuntu Server,where I each time have to update the 
code.So I am using 
git clone *https://*mddhdu131...@bitbucket.org/mddhdu131313/xhdlcdare.git 
to clone everytime.I know this method sucks. :( 
So I tried using git in EC2 
I installed git 
 sudo apt-get install git
I also appended the bitbucket's key to authorized_keys file.
But I tried cloning via git
root@ip-dd-1d7-95-ddd:/var/www/test/git_test# git init
Initialized empty Git repository in /var/www/test/git_test/.git/
root@ip-dd-aad-5-14d:/var/www/test/git_test# git clone 
Cloning into 'dhilcare'...
Permission denied (publickey).
fatal: The remote end hung up unexpectedly.

The thing is that each time I want to change something in the server want 
to commit and  push the code from there  to my bitbucket.I was not able to 
do that.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to