I've seen many threads and blog posts about my problem but none of them 
solved my problem, so I'll ask here if anyone has encountered the same 

I'm attempting to deploy my website via github. I have created a bare 
hub.git repo on the server, I push my local git repo to it, checked if it 
worked with a git log and everything was fine.

I then cloned this repo on the server in a repo called dev and made a 
virtual host for it and everything shows up fine.

I used to push from local to hub and then pull hub from dev and it worked 
fine. I wanted to automate this, I wanted to be able to push from local to 
hub and automatically pull hub from dev. So I created a post-update file in 
hub.git/hooks and put this in it : 

echo "***** updating on dev *****"
cd /../dev || exit
unset GIT_DIR
git pull origin master

I then made sure that my post-update was executable with a 

   chmod +x hooks/post-update

Went back to my local repo, changed a file

   git add .
   git commit -m "testing"
   git push origin

This message comes up

   remote : 
   remote : ***** updating on dev *****
   remote : 
   remote : fatal: Not a git repository (or any parent up to mount point /dev)
   remote : Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM 
not set).

I checked and there is a .git in my dev directory and the HEAD hasn't been 
renamed or anything. However I do have a HEAD, a FETCH_HEAD and a 
ORIGIN_HEAD (don't know if that would change anything).

I'm not sure what the problem is here. The server is a gentoo x86 (if that 
might help at all). Sorry if I'm just missing something obvious or if this 
isn't the place to post this.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to