After 'git submodule update' your submodule is checked out at given ish so 
it's put onto 'no branch'.

If you know that it's f.i. master you can:
 * cd submodule
 * git checkout master
 * do your work && commit
 * cd to main repo
 * git add submodule && git commit

W dniu niedziela, 19 maja 2013 18:15:17 UTC+2 użytkownik Surya napisał:
> We have a project and its under Git.. and a directory under the project 
> has its own Git rep (a submodule).
> We are having two different repos' on Github and my maintainer, linked one 
> into another.. I just cloned the main repo, 
> and followed 
> $ git submodule init
> $ git submodule update
> I worked on the code and pushed the local branch (where I worked) to the 
> Github before sending PR. Now, here is the deal, I don't see the submodule 
> - git repo to be updated.
> When I changed the dir into submodule
> and executed
> $ git branch
> I found
> * (no branch)
>   master
> How to fix my stuff now? 
> Thanks

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to